Welcome to the ITS status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Issue with Network Connections for Mead/ENREC, Sidney High Plains Ag Lab Identified
Incident Report for IT
Resolved
This incident has been resolved.
Posted Mar 26, 2021 - 17:43 CDT
Update
Update: Vendor will be performing final remediation at 5PM to fully resolve the outage.
Posted Mar 26, 2021 - 10:35 CDT
Monitoring
All sites restored. We continue to monitor and engage the carrier for long term repairs.
Submitted by Kristy Kennedy
Posted Mar 26, 2021 - 10:03 CDT
Update
Update: University engineers have temporarily mitigated the service impacting outage caused by the carrier power equipment. Additional maintenance will need to be performed by the carrier to fully resolve the outage.
Posted Mar 26, 2021 - 09:57 CDT
Update
Update: ITS has identified a failure in the Charter/Spectrum cabinet and have communicated the source of the outage to the carrier. Attempts to mitigate the outage continue while we work with the carrier. Second level escalation with Spectrum.
Posted Mar 26, 2021 - 09:39 CDT
Identified
Potential problem with Network Connections for Mead/ENREC, Sidney High Plains Ag Lab is under investigation. Charter/Spectrum is aware of an issue out of Grand Island. Users are experiencing a complete outage due to this event on the carrier network. The cause of the outage is unknown at this time. We are actively working with the carrier to resolve the outage.
Updated by Kristy Kennedy
Posted Mar 26, 2021 - 08:14 CDT
This incident affected: Infrastructure (Network Nebraska, Research Center & Extension Connections).