Welcome to the ITS status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: mysupport@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
UNK imagenow under investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Updated by Bryan Fitzgerald
Posted 15 days ago. Jan 02, 2019 - 12:27 CST
Investigating
Potential problem with imagenow is under investigation. Technicians are investigating the issue.
Reported by Byran Fitzgerald
Submitted by Kevin Hopper
Questions 402-472-3970 or mysupport@nebraska.edu
Posted 15 days ago. Jan 02, 2019 - 11:25 CST
This incident affected: Administrative | Business (Business Applications (other)).