Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
Code has been identified that is causing errors when opening Excel files. Engineers are developing a fix for the issue and anticipate that it will take time to complete. Once the fix is ready, they will begin deploying to the affected environment to remediate the impact.
Posted Jun 11, 2026 - 08:19 CDT
Update
Scope of Impact:
Users accessing subsites with unique permissions not inherited from the parent site on SharePoint Online aren't able to access files in Excel for the web browser.
Latest Update from Microsoft:
We've determined that the recent update isn't the cause of impact. We're analyzing other recent updates along with testing additional service-side reproductions of this issue to isolate the root cause.
Posted Jun 10, 2026 - 16:45 CDT
Investigating
Users can't access Excel files through browser from SharePoint Online.
Posted Jun 10, 2026 - 11:48 CDT
This incident affects: Communication & Collaboration (Microsoft 365 - Sharepoint / OneDrive (Storage)).