Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Digital signage management portal issue identified
Incident Report for IT
Resolved
This incident has been resolved.
Posted Jan 24, 2023 - 16:40 CST
Monitoring
Poppulo has restored our access to the Devices module in fwicloud.com. This issue will be monitored for the remainder of the business day to ensure it does not reoccur.
Posted Jan 24, 2023 - 15:16 CST
Identified
Poppulo has identified the issue and is applying a fix.
Posted Jan 24, 2023 - 15:10 CST
Investigating
An issue with the Devices module in fwicloud.com is being investigated. Users may see an access denied message, or the module may display but no folders or sign devices appear. A ticket has been submitted to Poppulo, and they're investigating.
Posted Jan 24, 2023 - 14:35 CST
This incident affected: Communication & Collaboration (Digital Signage).