Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
NCTA unable to take Inbound calls
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Updated by Timothy Gunther
Posted Jun 25, 2020 - 18:08 CDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 25, 2020 - 17:12 CDT
Identified
Unable to receive inbound calls working with vendor to resolve the issue
Reported by Mike Hansen
Questions 402-472-3970 or support@nebraska.edu
Posted Jun 25, 2020 - 17:07 CDT
This incident affected: Communication & Collaboration (Telephone Services).