Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
All systems are operating normally. This issue is resolved.
Posted Mar 05, 2026 - 12:28 CST
Monitoring
Service is starting to recover, repairs are still on-going.
Posted Mar 04, 2026 - 18:40 CST
Update
The carrier is half way done splicing.
Posted Mar 04, 2026 - 16:57 CST
Update
Excavation is on-going and a replacement cable is being prepared. Restoral time is still 5:30pm CT.
Posted Mar 04, 2026 - 15:05 CST
Identified
The carrier has confirmed that this is due to fiber damage and they have an estimated restoral time of 5:30pm CT.
Posted Mar 04, 2026 - 13:18 CST
Update
The carrier is continuing to work towards isolating the cause of the outage.
Posted Mar 04, 2026 - 11:44 CST
Investigating
Valley County Extension went down at 9:52am CT. Other monitored sites in the area went down at the same time. We are engaging the carrier now, no time of restoral is available.