Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at its.nebraska.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: nusupport@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska

Canvas under heavy load

Incident Report for IT

Monitoring

Instructure has implemented a fix for this issue, and we are seeing signs that the system is beginning to respond as expected. ITS will continue to monitor the situation to ensure services remain stable and will provide additional updates as they become available.
Posted Aug 31, 2026 - 15:31 CDT

Update

Nationally, Instructure continues to work to resolve an issue related to heavy load on their systems. University of Nebraska faculty and students may experience sluggishness or longer wait times when logging in to Canvas. Some users may see a message stating, “This website is under heavy load (request timed out).” If you receive this error, please refresh the page and try again. ITS will continue to monitor the situation and provide updates as they become available.
Posted Aug 31, 2026 - 13:36 CDT

Update

Nationally, Canvas has reported errors related to a heavy load on their system and they are investigating the issue. University of Nebraska faculty and students may observe sluggishness or longer wait times to log in to Canvas.
Posted Aug 31, 2026 - 12:56 CDT

Investigating

Nationally, Canvas has reported errors related to a heavy load on their system and they are investigating the issue. University of Nebraska faculty and students may observe sluggishness or longer wait times to log in to Canvas.
Posted Aug 31, 2026 - 12:55 CDT
This incident affects: Teaching & Learning (Canvas).