Welcome to the ITS status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
ITS Billing Application under investigation
Incident Report for IT
Resolved
This incident is related to the Microsoft 365 services under investigation.
Posted Apr 01, 2021 - 17:17 CDT
Investigating
Potential problem with ITS Billing Application is under investigation. Technicians are investigating the issue. Vendor has been notified.
Reported by Mel Primus
Submitted by Jillian Dicke
Questions 402-472-3970 or support@nebraska.edu
Posted Apr 01, 2021 - 17:13 CDT
This incident affected: Administrative & Business (Business Applications (other)).