Welcome to the ITS status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Canvas under investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Updated by Kristy Kennedy
Posted Mar 25, 2021 - 12:32 CDT
Monitoring
From 7:48 am - 9:12 am this morning, Canvas instances worldwide experienced intermittent timeout errors and slow loading times. The vendor implemented a fix and the service is now stable. NU ITS teams continue to monitor the issue and will communicate any changes.
Submitted by Loren Frerichs
Posted Mar 25, 2021 - 09:28 CDT
Update
Since 7:48 am, Canvas instances worldwide have been experiencing intermittent timeout errors and slow loading times. Canvas has identified the issue and is working on implementing a fix. NU ITS will continue to keep you updated as we learn more.
Updated by Loren Frerichs
Posted Mar 25, 2021 - 09:06 CDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 25, 2021 - 09:06 CDT
Identified
The cause of the Canvas issue has been identified and steps are being taken to remediate impact to affected services.
Updated by Kristy Kennedy
Posted Mar 25, 2021 - 08:14 CDT
Investigating
A potential problem with Canvas is under investigation. Technicians are investigating the issue. also see https://status.instructure.com/incidents/nh54zws7981c
Reported by Mike Zimmerman
Submitted by Loren Frerichs
Questions 402-472-3970 or support@nebraska.edu
Posted Mar 25, 2021 - 08:04 CDT
This incident affected: Teaching & Learning (Canvas).