Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
All systems are operating normally. This issue is resolved.
Posted Aug 13, 2025 - 08:08 CDT
Monitoring
All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems.
Posted Aug 12, 2025 - 07:47 CDT
Identified
ITS will be implementing a fix to all impacted locations starting this evening at 7:00PM. If you continue to have issues Tuesday morning, please contact your IT support team or the ITS Help Center.
Posted Aug 11, 2025 - 14:49 CDT
Update
We are continuing to investigate this issue. Users who are unable to connect to the wired network on campus should use the eduroam wireless network at this time as a temporary workaround.
Posted Aug 11, 2025 - 09:38 CDT
Investigating
A problem with wired network connectivity is under investigation. Technicians are investigating the issue.