Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
The Scheduled work for tonight is complete and all systems are functioning normally
Posted Apr 22, 2025 - 21:58 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 22, 2025 - 19:00 CDT
Scheduled
RFC 111367: Telephones will have reduced performance during maintenance. Direct impact: CallManager self-care portals and Jabber users will not be able to login while we are updating. ITS will be updating certificates to comply with Google restrictions during this time. Entered by - Loren Frerichs Questions 402-472-3970 or support@nebraska.edu
Posted Apr 18, 2025 - 11:48 CDT
This scheduled maintenance affected: Communication & Collaboration (Telephone Services).