Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
All systems are operating normally. This issue is resolved. Updated by Bryan Fitzgerald
Posted Jan 26, 2026 - 08:47 CST
Monitoring
Most issues have been resolved, with the exception that some users may still be unable to access Outlook on the web. All other services are fully operational, and systems are performing as expected. We will continue to monitor for any recurring issues. Submitted by Bryan Fitzgerald
Posted Jan 23, 2026 - 07:38 CST
Identified
The vendor has identified the cause of the issues and is taking steps to remediate impact to affected services. Updated by Bryan Fitzgerald
Posted Jan 22, 2026 - 21:53 CST
Investigating
A problem with MS365 services is under investigation. Email does appear to be impacted. Technicians are investigating the issue. Reported by Eric Haffey Submitted by Bryan Fitzgerald Questions 402-472-3970 or support@nebraska.edu
Posted Jan 22, 2026 - 14:33 CST
This incident affected: Communication & Collaboration (Microsoft 365 - Outlook (Exchange Online), Microsoft 365 - Teams (Communication & Voice), Microsoft 365 - Teams (Collaboration & Storage), Microsoft 365 - Sharepoint / OneDrive (Storage), Microsoft 365 - Other Apps (PowerApps, Office, etc...), Microsoft 365 / ProofPoint - Email Deliverability & Processing).