Welcome to the ITS status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
EvaluationKIT Under Investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Updated by Timothy Gunther
Posted Oct 14, 2020 - 16:47 CDT
Monitoring
Issues appear to have subsided, system stability has increased significantly. ITS and our vendor continue to monitor for any problems.
Submitted by Loren Frerichs
Posted Sep 29, 2020 - 17:24 CDT
Update
Our vendor has upgraded two servers, and is making other adjustments to improve performance. Some users may continue to experience site slowness.
Submitted by Murtda Mohammed
Questions 402-472-3970 or support@nebraska.edu
Posted Sep 22, 2020 - 15:40 CDT
Investigating
Potential problem with EvaluationKIT is under investigation. Technicians are investigating the issue. Some users are experiencing site slowness or issues accessing EvaluationKIT.
Reported by Ben Lass
Submitted by Kristy Kennedy
Questions 402-472-3970 or support@nebraska.edu
Posted Sep 21, 2020 - 11:25 CDT
This incident affected: Teaching & Learning (Academic Technologies (Other), Canvas).